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Welcome

VirtualRig™ Studio is professional software for
realistic motion blur simulation in traditional
photography and CGI. This document describes
all the application features and explains the
complete workflow using an example project.
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User interface

The user interface of VirtualRig™ Studio was designed 
to be as intuitive as possible. The main area of the 
application window contains a workspace where you 
define how the motion blur effect is applied to your
image. On the left side, there is a control panel where 
you can change various project settings. The toolbar
in the top part of the window allows you to quickly
access the most important features from the main 
menu.

Simply put, the motion blur effect is guided by vectors 
which are drawn onto the source image. The position 
and shape of each vector determines the shape of blur 
in particular areas of the image. To draw a vector,
click       icon in the toolbar, click into your image and 
drag the vector to set its length. To move the vector or 
change its shape, click       and drag one of the vector’s 
control points. If you click and drag elsewhere a selec-
tion rectangle will appear which helps you to change 
the shape or location of multiple vectors at a time.

Introduction
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Vectors and blurrers
Start length: 123px

Start length: 123px

Start length: 15px

End length: 0px

End length: 100px

End length: 200px

Vector

Start of a vector (displayed as a small circle) defines 
location of the blur and the middle and end points 
define its shape. The overall motion blur of a picture is 
smoothly interpolated to match all vectors in their loca-
tions.

Blurrer

Even though a single vector is sufficient to blur a whole 
image, typically more than one vector is needed to 
non-uniformly blur different areas of the image. And 
this is where the blurrer tool comes in - it allows you 
to define a sequence of vectors, whose location and 
shape precisely matches the shape of the blurrer. Use 
the small circles at the start and the end of blurrer to 
set the lengths of corresponding vectors. If you move 
the mouse cursor over the circle, you can also type the 
length with your keyboard.

Blurrer layout: Render

Introduction
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Transparent images

VirtualRig™ Studio Pro supports blurring of TIFF
and PNG images with 8-bit alpha channel. This feature 
is necessary if you need to blur different plans with 
different speeds. In the example on the right the forest 
background is blurred with a slower speed than
the front plan (the stones on the bridge and the tree
in particular). The two resulting layers were then
combined in Adobe Photoshop.

Please note that the render output format needs
to be set to TIFF or PNG in order to preserve the alpha 
channel in the resulting image.

Static picture

Transparent front plan blurred in lower speed

Background combining different speeds of front plan

VirtualRig™ Studio layout with blurrers

Another render in higher speed

Final composition

Introduction

This scene is included in example projects.
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Project settings

The project settings dialog controls several important 
properties of your project which have a direct effect on 
how your picture is blurred.

20 km/h 50 km/h 100 km/h

Speed coefficient effect

Colors

Allows you to change colors of 
vectors and blurrers. This setting 
might save your day when working 
on a picture with a background color 
similar to default color settings.

Speed coefficient

This setting virtually changes the 
length of all vectors in the project, 
without moving a single vector - see 
the example below. The value 1.0 
means that the length of vectors is 
as displayed.

Margin approximation

Margin approximation: Near the 
border of the image there are not 
enough pixels to generate the blur 
effect from. This setting specifies 
how the missing pixels are approxi-
mated. Try a different setting if you 
experience some strange artifacts 
around your image borders. Alterna-
tively, you can try using a negative 
speed coefficient or inverting all 
vectors (in menu Edit -> Invert) to 
suppress these artifacts.

Realtime preview

If checked, the current render is 
displayed in the workspace instead 
of the original image.

Control panels

http://virtualrig-studio.com


© 2008-2015 VirtualRig™ Studio s.r.o.
All rights reserved.

www.virtualrig-studio.com

3.03.0VirtualRig™Studio

HDRI

VirtualRig™ Studio supports high-dynamic-range
images (HDRI) stored in Radiance 32-bit RGBE
or OpenEXR formats. HDRI images preserve more
luminance information than traditional image formats 
and they are often used to store high-resolution
panoramic images, although panorama and HDRI
are independent features. To preserve HDRI features
in your final render don’t forget to go to RENDER
SETTINGS panel and set the format to HDRI or EXR. 
Note that this feature is only available in Pro version.

Spherical image mode

Enables smooth blurring of 360° 
horizontal panoramic pictures.
See next page for details.

HDRI exposure value

Controls the brightness of the HDRI 
image in the workspace and during 
the render to a traditional image 

HDRI exposure value: 2.0 HDRI exposure value: 9.0

Control panels

This scene is included in example projects.
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Spherical image mode

The spherical image mode simplifies blurring of 360-de-
gree horizontal panoramic images, because it ensures 
that the right and left side of the blurred image can 
be again smoothly joined in a panoramic sphere. Such 
spheres are typically used for rendering of photorealistic 
blurred reflections on CGI models of cars in third-party 
3D rendering tools such as VRED - see example below. 
If the spherical image mode is enabled, the workspace 
will display mirrored copies of all vectors and blurrers 
to help you see how the motion blur will be applied to 
the image. Note that this feature is only available in Pro 
version.

Spherical image mode

Enables smooth blurring of 360-de-
gree horizontal panoramic pictures. 
Please find more information in the 
following pages.

Control panels

This scene is included in example projects.
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HDRI spheres examples

This is an advanced example of an HDRI spherical 
image blur to give photorealistic reflections to your 
render.

Control panels

Static reflection without blurred HDRI 

Blurred HDRI sphere saved into *.hdr Static backplate and the layout of blurrers. 

Photography and CGI  by René Staud Photography.

Blurred HDRI sphere in reflections.
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Overlay layer

This panel enables you to display a static overlay layer 
over your workspace. For example, you can use it to 
display a picture of a car that might help you correctly 
align blur vectors with its direction.

Image size

Displays information about overlay 
image resolution.

Scale to fit

 If checked, the overlay image is 
scaled to fit the workspace image.

Add to render

If checked, the overlay image is also 
included in the render output.

Source file

Path to the overlay image file. PNG 
and TIFF files are supported.

Enabled

If checked, the overlay layer will
be displayed.

Opacity

Controls the transparency of the 
overlay image.

Transparent layer + backplate Workspace with real-time preview and overlay layer enabled

This scene is included in example projects.

Watch tutorial video: https://vimeo.com/122418094

Control panels
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Jitter effect

Back in the days of physical camera rigs, vibrations
of the rig could produce some strange artifacts
in the photos. You can emulate these imperfections
in the jitter effect panel. Random

For your convenience, use this button 
to randomly generate the jitter effect 
parameters instead of setting them 
all manually.

Enabled

If checked, the jitter effect
is included in the render.

Longitudinal amplitude/frequency

Magnitude and frequency of rig 
vibrations along its movement.

Noise level

Amount of artificial randomness
in rig vibrations.

Noise memory

Auto-correlation of the randomness 
in rig vibrations.

Lateral amplitude/frequency

Magnitude and frequency of rig 
vibrations perpendicular to its 
movement.

Without jitter effect With jitter effect

Watch tutorial video: https://vimeo.com/122418093

Control panels

This scene is included in example projects.
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Render settings

This panel controls where the rendered images are 
stored, the quality of the render as well as its speed.

Format

Specified the output image format. 
In Trial and Lite versions, only JPEG 
is available. In Pro version, you can 
also select TIFF, PNG, GIF, BMP, HDRI 
and EXR formats. Note that for JPEG 
format you can additionally specify 
compression quality and for TIFF 
format, you can specify compression 
type.

Noise level

Sometimes the motion blur effect 
creates ugly periodic artifacts in the 
rendered image. The noise level 
setting adds a random noise to the 
blur to avoid these artifacts. The 
value is specified in pixels, the higher 
the value the more noise is added. 
The noise can also serve your artistic 

Original image size

Indicates the original resolution of 
the workspace image, which might 
be helpful when deciding on your 
render resolution.

Width / Height

Desired width and height of the 
output image.

Output file

Specifies the image file where 
the next render will be saved. By 
default, VirtualRig™ Studio saves 
rendered images to the VirtualRig 
renders sub-directory next to your 
project file. If the file name ends 
with a three-digit number, the num-
ber is automatically incremented 
after every render to ensure the files 
have unique names.

Lock aspect ratio

If checked the ratio between original 
width and height will be preserved 
when changing width or height.

Scaling

Select the algorithm used for image 
resizing. Bicubic offers the best
quality but is slowest, nearest neigh-
bor has a lower quality but is fast.

Render type

Specifies the type of output, see next 
page for details.

Show result after rendering

The type of the render: Blur or Cur-
vature. Please see the next page for 
details.

Control panels
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Render type

VirtualRig™ Studio offers two types of render output: 
motion blur and motion paths.

The first option generates the normal motion blur,
while the latter option only displays the curvature
and intensity of the blur. You will find motion paths
useful to fine-tune the motion blur in every area
of the image in order to achieve exceptional quality
of your renders.

Render type: Motion Blur

Render type: Motion Paths / Grid size 25x25 px Render type: Motion Paths / Grid size 50x50 px

Control panels
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Render queue

Don’t feel like waiting 10 minutes for your high-resolu-
tion render? No problem, just add it to the queue and 
continue your work. Multi-core rendering is now also 
supported.

Remove

Removes a specific render from the 
queue. The rendering process will
be aborted if it already started.

Render image

Adds the current state of the project 
with all its settings to the render 
queue. The rendering will start 
immediately if the queue is empty. 
Note that this button performs the 
same action as       button in toolbar.

Control panels
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Create new project

In the following tutorial we explain how to blur
a real-world image, step by step.

The first step is to prepare the source image. If the 
image contains a car, you will need to erase it from 
the image or at least erase its border parts that would 
interfere with the blur. To do that, you can use standard 
tools in Adobe Photoshop or any other graphical
software. Additionally, you might export the clipped
car into a separate image and use it as overlay layer.
Of course, if your picture is a pure background with
no car, you can skip this step.

When your source image is ready open it in VirtualRig™ 
Studio using menu File > Open ... It is reasonable to 
save your project to disk from time to time using menu 
File > Save. Note that VirtualRig™ Studio projects are 
saved in files with VRS file extension.

Watch tutorial video: https://vimeo.com/122418092

Tutorial

This scene is included in example projects.
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Draw first vector

Now that the source image is ready and opened in 
VirtualRig™ Studio, you can start drawing blur vectors. 
In our sample scene we want the motion blur to follow 
the curved road, so it is better to use the blurrer tool 
[1] instead of many hand-drawn vectors (the difference 
between vectors and blurrers is explained in Introduc-
tion). In drawing mode you can press and hold ALT 
key to quickly switch to the select & move mode which 
enables you to move the control points of the blurrer 
- we need it to change the length of blur in the area [2 
and 3]. In general, objects close to the camera move 
faster than objects in the background, hence the start 
length is much longer than the end length. If you hover 
the mouse cursor over the blurrer you will see all the 
information about it on the status bar [4], including cor-
responding vector lengths. Note that you can set these 
length precisely by typing the number of pixels on your 
keyboard.

Render type: Motion Blur Render type: Motion Paths

1

2

3

4

Tutorial
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Keep adding more blurrers. The general rule is the 
more blurrers (or vectors) the better the result. It is 
important to shape the blurrers to follow the direction 
of the assumed car movement and to set the length of 
vectors appropriately. Drawing of vectors is very intui-
tive and it doesn’t take much time to get a good feeling 
for it.

If you have an overlay image with the car, now it’s
a good time to include it to your project using the over-
lay layer [1] panel so that you can correctly align the 
blurrers with the car.

With real-time render preview turned on [2] you can 
instantly see the effect of each newly added blurrer. To 
fine-tune the blur effect you might change the render 
type [3] to motion path (see render settings panel for 
details). When all the blurrers are in place, you might 
also consider adding jitter effect [4]. If everything looks 
good, it’s time to perform the final render. Set the de-
sired parameters in the render settings panel and click 
Render [5]. It’s a good idea to add few more renders 
with a different speed coefficient setting so that you’ll 
have more images to choose from.

Adding more vectors
and Rendering

2

1

4

5

3

Tutorial

Render type: Motion Blur Render type: Motion Paths
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When the blurred background is ready, it’s time to do 
the final composition and post-production of the image. 
When talking about classical photography of cars you 
will usually face two issues: wheels and reflections. From 
our experience, the best and easiest way how to “spin” 
the wheels of a stationary car is to use real pictures of 
spinning wheels and superimpose them to the image of 
the car using Adobe Photoshop or any other graphical 
software. The results look absolutely realistic.

It is possible to use VirtualRig™ Studio to blur the re-
flections - essentially you need to use another graphical 
software to extract the reflections, blur them as a sepa-
rate project in VirtualRig™ Studio and superimpose 
them back to the car image. However, the details of 
this procedure are beyond the scope of this tutorial. In 
the case of 3D models of cars handling of reflections is 
easier - you can create a 360-degree blurred panoramic 
image and use it as a background for the render of your 
3D car model - see spherical image mode for details.

Final composition

Tutorial
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Can I upgrade an already purchased Lite version to a full Pro version?
Yes, you will only pay the difference between the Lite and Pro version. Please contact us to arrange for such an upgrade.

Floating licenses need internet connection, but what if I’m offline and still want to use VirtualRig™ Studio?
That’s no problem, you can be offline for up to one week and the application will continue working normally.
If you want to extend this period to two weeks while you’re still online, please go to Help > License manager and click Renew.

Can I use VirtualRig™ Studio without internet connection?
Yes, it’s possible, we can send you a license file by email that will enable you to start the application without internet connection.
Please contact us for details.

How can I transfer my copy of VirtualRig™ Studio to another computer?
First, you need to deactivate the application on the old computer. Just go to Help > License manager and click Deactivate. After that you 
can activate the application on a new computer using your activation code. This applies to both fixed and floating licenses.

What is the difference between fixed and floating licenses?
With both fixed and floating licenses you can transfer your copy of VirtualRig™ Studio to another computer. However, with a fixed license 
you can only do it once every few months while with a floating license you can do it any time.

I already bought VirtualRig™ Studio 2.3. How can I upgrade to version 3.0?
We sent all our customers an email with information about how to upgrade.
If you didn’t receive it, please contact us and we’ll look after you.

Do you offer student discounts?
We don’t offer any special discounts to students, in a hope that the Lite version is affordable to everyone.
However, contact us if you think different, we might make an exception.

FAQ
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What are the hardware requirements of VirtualRig™ Studio?
VirtualRig™ Studio can be used on every computer running Windows XP Professional or Mac OS X 10.5 (Leopard), or any newer version
of these operating systems. However, in order to open and render large images, you will need at least 2 gigabytes of RAM installed
on your system. Also, more CPUs will make your render finish a lot faster.

Is it better to point the vector in the car’s direction or the opposite direction?
Actually, a physically ”correct” approach is to point the vectors in the opposite direction of the car’s movement. However, people
sometimes point the vectors in the direction of the car and also get appealing results. It really depends on what works better for you.
Note that you can easily swap the vector direction using the Invert tool in Edit menu.

How can I make car wheels look spinning?
Although it’s possible to blur wheels to make them look spin, it’s very difficult to do so in a photo-realistic fashion. That’s because the shape 
of the rims produces very distinct artifacts in the photos that cannot be reproduced from static pictures. Also, some parts of the wheels such 
as brakes don’t spin at all and therefore shouldn’t be blurred. In order to get finest results, we recommend to use separate photos
of spinning wheels and superimpose them to the static photos of cars.

Does VirtualRig™ Studio support non-standard ICC color profiles?
No, the application only supports sRGB ICC color profile. If you open a picture with a different color profile, the colors might look shifted. 
Please convert your image to sRGB before opening it in VirtualRig™ Studio.

FAQ
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Keyboard Shortcuts

Task	 MAC	 WIN	   ICON

Create new project	 ⌘ + N	 Ctrl + N

Open existing project	 ⌘ + O	 Ctrl + O

Save project	 ⌘ + S	 Ctrl + S

Save as project	 Shift + ⌘ + S	 Ctrl + Shift + S

Close project	  ⌘ + W	 Ctrl + W

Quit VirtualRig™ Studio	 ⌘ + Q	 Ctrl + Q

Undo	 ⌘ + Z	 Ctrl + Z

Redo	 Shift + ⌘ + Z	 Ctrl + Shift + Z

Select and move objects (press and hold Alt key when in drawing mode)	 V	 V

Select all	 A	 Ctrl + A

Draw new vector	  ⌘ + D	 D	

Draw new blurrer	 C	 C

Zero vector’s length	 0	 0

Straighten vector	 9	 9

Move canvas view  (press and hold Space)	 H	 H

Remove selected objects	 Backspace	 Backspace

Zoom in	 Z	 Z

Zoom out  (press and hold Alt during zoom)	 Alt + Z	 Alt + Z

Zoom to full extent	 E	 E

Control panel	 P	 P

Change image	 I	 I

Render	 R	 R

Results viewer	 W	 W

VirtualRig™ Studio provides keyboard shortcuts
to help you quickly perform tasks otherwise available
in the menu. Most of the keyboard shortcuts are also 
displayed in the menu next to the command name
or when you hover the mouse over the corresponding 
toolbar buttons.
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Provided by:

VirtualRig Studio s.r.o.
Mikovcova 548/5
120 00 Prague 2
Czech Republic

VAT ID: CZ28485378

Follow us on Facebook and be the first one
to know the latest news.

facebook.com/virtualrigstudio

If you have any questions, comments or feature requests,
do not hesitate to contact us at the following email

support@virtualrig-studio.com

Contact and support
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